Google Search Console Alert: Recommended WordPress Update

Does this sound familiar to you? You just received a Google Search Console Alert telling you that you have outdated WordPress themes or plugins on your website and that you need a WordPress update. Perhaps this email also notified you that your website could be vulnerable to malware or hacking exploits.

If you have received an email similar to this, don’t panic! All software will need to be updated at one point or another, but it’s best to make sure you take care of those updates as soon as possible.

Example Email


Google Search Console
Recommended WordPress update available for http://www.wordpressuser.com
To: Webmaster of http://www.wordpressuser.com/
Google has detected that your site is currently running WordPress 4.7.0 or 4.7.1, an older version of WordPress. Outdated or unpatched software can be vulnerable to hacking and malware exploits that harm potential visitors to your site. Therefore, we suggest you update the software on your site as soon as possible.
Following are one or more example URLs where we found pages that have outdated software. The list is not exhaustive.
http://www.wordpressuser.com/

Recommended Actions:
1. Update to the latest release of WordPress. Visit the WordPress site for instructions on how to download and install the latest release.

2. Check your site for hacked content. Because there was a vulnerability on your site, it’s possible that your site might have been compromised. We recommend you check your site for any suspicious activity. You can see if Google has detected any hacked content on your site in the Security Issues section of Search Console.

3. Stay up to date on new releases. Remember that older or unpatched software might be vulnerable to hacking or malware, so it’s important to install new software releases when they come out.

You may have received an email like the one above. Don’t panic if you have.

 

Why is Google Search Console sending this email?

You received a Google Console WordPress Update notification because your WordPress software is out-of-date. This means that WordPress has come out with a new version of the software, and your site needs to be updated to this newer version. If your software is out-of-date, this may mean that the plugins and themes on your website may need to be updated as well. This is also important to check up on.

Why do I need to update my WordPress software?

When companies, such as WordPress, update their software, it means that they have improved the software in some way. They may have added some new features, fixed some bugs found in the previous software, or they may have improved the overall software security. If you do not update your WordPress software, you run the risk of having your site be hacked since the outdated software is a security vulnerability. Because of this, it is important to update your software as soon as possible.

Should I be concerned?

Possibly.  Because your software is out of date, your site may have been hacked. Check for any signs on your website that may indicate your website has been compromised. If you find that you have been hacked, you do need to fix this as soon as possible.

If my site has been hacked, what do I do?

We can help you! We provide hacking insurance, which means we can help prevent your site from becoming hacked, and we can fix your site if it is currently hacked. Click here for more information.

How do I update WordPress?

WordPress provides instructions on how to update your software. Click here to go to their page. If you don’t have time to update your website, or you’re still unsure how to update it, we can do this for you! Click here to see the benefits we offer.

We can help!

Our main concern is that your website is running properly, efficiently, and safely. This is why we offer packages with hacking insurance, and plans that allow us to update and maintain your site for you. Learn more about our packages here.

 

We understand receiving emails like these can be stressful. By sending these emails out, Google Search Console is trying to help you know which updates are available so that you can make sure your site is up-to-date and protected. Updating your WordPress software is crucial. If you don’t have time to update your WordPress software, or any other add-ons, we can do this for you! We can help you have peace of mind knowing that your website is up-to-date and well maintained, while also helping you avoid receiving any more of these emails. Click here to see our plans.

 

Recommended Posts

Leave a Comment